Openvpn 2.4+

Συζήτηση στην κατηγορία 'Εφαρμογές [Ερωτήσεις - Απορίες]' που ξεκίνησε ο χρήστης debianass, 14 Ιαν 2017.

  1. Η νέα έκδοση openvpn 2.4+ παρουσιάζει κάποιες ασυμβατότητες σε σχέση με τις προηγούμενες εκδόσεις 2.3*.
    Πρακτικά, στις νέες εκδόσεις:
    1. Δεν θα λειτουργήσει η επιλογή tls-remote. Οπου χρησιμοποιείται θα πρέπει να αντικατασταθεί με verify-x509-name.
    2. Οι ρυθμίσεις δεν αποθηκεύονται πλέον στο /etc/openvpn αλλά στο /etc/openvpn/server ή /etc/openvpn/client κατα περίπτωση.
    3. Η systemd υπηρεσία [email protected] έχει επίσης διαχωριστεί σε [email protected] και [email protected]
    4. Εχει αλλάξει επίσης η διαδρομή αναζήτησης των plugins.

    Στον τελικό χρήστη, πέρα από τη χρήση του ίδιου τoυ openvpn, αυτό θα έχει επίπτωση στην εκτέλεση εφαρμογών που χρησιμοποιούν openvpn, όπως η έκδοση skype 4.3.0.37 που δε θα μπορεί να συνδεθεί με microsoft account (απαιτεί tls-remote), το bitmask vpn που δε θα επιστρέφει το status σύνδεσης κ.α.
    Η νέα έκδοση (web based) του skype ωστόσο δε θα παρουσιάσει καμιά ασυμβατότητα με το openvpn 2.4+.
    Η τελευταία έκδοση bitmask 0.9.2 θα συνδεθεί κανονικά στο δίκτυο VPN αλλά θα δείχνει ότι δεν συνδέεται.
    Οι χρήστες που θέλουν να χρησιμοποιούν την παλιότερη έκδοση του skype, να λειτουργεί κανονικά ο bitmask vpn client και όσες ακόμα εφαρμογές παρουσιάζουν ασυμβατότητα με τη νέα έκδοση, θα πρέπει να παραμείνουν στην έκδοση 2.3* openvpn τουλάχιστον μέχρι να αναβαθμιστεί ο κώδικας των εφαρμογών τους.
    Οι αλλαγές ισχύουν για όλες τις διανομές linux που αναβαθμίζουν το openvpn στην έκδοση 2.4+.
  2. ευχαριστουμε για την ενημερωση :good
  3. Μια σχετική ενημέρωση αφορά στη νέα έκδοση του Bitmask (0.9.2.1) η οποία είναι πλήρως συμβατή με το openvpn 2.4+. Είναι κάτι αναμενόμενο αφού το debian stretch βρίσκεται στη διαδικασία περάσματος σε stable και χρησιμοποιεί τις νέες εκδόσεις openvpn. Ανάλογη είναι και η ανάπτυξη άλλων διανομών που περιλαμβάνουν τη νέα έκδοση openvpn καθώς και των παράγωγων διανομών (ubuntu based). Αργά ή γρήγορα όλες οι εφαρμογές που επηρρεάζονται θα εναρμονιστούν με τη νέα έκδοση openvpn.
    Η ενημέρωση στη νέα έκδοση Bitmask θα γίνει αυτόματα για όσους χρησιμοποιούν τη standalone version (έκδοσης 0.7+) ενώ για στην εγκατάσταση μέσω των αποθετηρίων θα γίνει κανονικά όταν θα ενημερώσουμε το σύστημά μας, με την προυπόθεση να είναι ενεργό το αποθετήριο bitmask.

    Υ.Γ. Η νέα έκδοση Bitmask είναι συμβατή προς-τα-πίσω, οπότε οι χρήστες παλαιότερης έκδοσης openvpn (π.χ. στο debian jessie) μπορούν άφοβα να το ενημερώσουν.