Πρόσφατη Αναβάθμιση FileSystem [How To]
#1
γεια σας
δινω pacman -Suy για να κανω αναβαθμιση αλλα δεν την κανει γιατι βγαζει το παρακατω.

Κώδικας:
[root@blackm76 makis]# pacman -Suy
:: Συγχρονισμός βάσεων πακέτων...
core ενημερωμένο
extra ενημερωμένο
community ενημερωμένο
multilib ενημερωμένο
:: Έναρξη πλήρους αναβάθμισης συστήματος...
επίλυση εξαρτήσεων...
διερεύνηση διενέξεων...

Πακέτα (57): bash-4.2.045-4  blender-8:2.67.57180-1  bluez-4.101-2  cdrkit-1.1.11-3  cheese-3.8.2-2  clutter-gst-2.0.4-2  coreutils-8.21-2  cryptsetup-1.6.1-2  device-mapper-2.02.98-4
            dhcpcd-5.6.8-3  e2fsprogs-1.42.7-2  filesystem-2013.05-2  fuse-2.9.2-3  gcc-4.8.1-1  gcc-libs-4.8.1-1  gconf-3.2.6-2  giflib-4.2.1-2  glibc-2.17-6  inetutils-1.9.1-6
            iproute2-3.9.0-2  iptables-1.4.19.1-1  iw-3.10-2  kmod-13-2  lib32-gcc-libs-4.8.1-1  libatasmart-0.19-2  libbonobo-2.32.1-4  libltdl-2.4.2-9  libmbim-1.0.0-1  libogg-1.3.1-1
            libsasl-2.1.26-4  libtool-2.4.2-9  lvm2-2.02.98-4  modemmanager-0.7.990-5  net-tools-1.60.20130531git-1  netctl-1.1-1  networkmanager-0.9.8.0-4  obex-data-server-0.4.6-6
            openobex-1.7-5  openresolv-3.5.4-3  pm-utils-1.4.1-6  ppp-2.4.5-6  rtmpdump-20121203-2  ruby-2.0.0_p195-1  sane-1.0.23-7  sed-4.2.2-3  shadow-4.1.5.1-6  strigi-0.7.8-3
            systemd-204-3  systemd-sysvcompat-204-3  sysvinit-tools-2.88-11  tar-1.26-4  udisks2-2.1.0-3  usbmuxd-1.0.8-2  util-linux-2.23.1-2  v4l-utils-0.9.5-2  wpa_supplicant-2.0-4
            zvbi-0.2.33-6

Συνολικό Μέγεθος Εγκατάστασης: 420,08 MiB
Καθαρό Μέγεθος Αναβάθμισης: 4,21 MiB

:: Συνέχιση εγκατάστασης; [Y/n] y
(57/57) έλεγχος κλειδιών                                                                                            [---------------------------------------------------------------------] 100%
(57/57) έλεγχος ακεραιότητας πακέτων                                                                                [---------------------------------------------------------------------] 100%
(57/57) φόρτωση αρχείων πακέτων                                                                                    [---------------------------------------------------------------------] 100%
(57/57) έλεγχος διενέξεων αρχείων                                                                                  [---------------------------------------------------------------------] 100%
σφάλμα: αποτυχία διεκπεραίωσης (διένεξη αρχείων)
filesystem: το /bin υπάρχει ήδη στο δίσκο
filesystem: το /sbin υπάρχει ήδη στο δίσκο
filesystem: το /usr/sbin υπάρχει ήδη στο δίσκο
Προέκυψαν σφάλματα, δεν αναβαθμίστηκαν πακέτα.
[root@blackm76 makis]#

γιατι το κανει αυτο;;;;;
τι πρεπει να κανω για να γινει η αναβαθμιση;;;;
  Απάντηση
#2
Ωχ,
από Αγγλικά πως πας..?

Είναι γνωστό πρόβλημα με την τελευταία αναβάθμιση του filesystem αλλά ΔΕΝ το αντιμετωπίζουν όλοι.
Εγώ ΔΕΝ το αντιμετώπισα.

Διάβασε εδώ:
Παράθεση:https://bbs.archlinux.org/viewtopic.php?id=164312

Επίσης εδώ
Παράθεση:https://www.archlinux.org/
έχει την λύση ο developer.

Αυτή η αρχική σελίδα του Arch, πρέπει να την επισκέπτεσαι ΠΡΙΝ από κάθε μεγάλη ενημέρωση που σου προτείνει ο pacman.
Δηλαδή, πατάς το n στην ερώτηση αν θέλεις να προχωρήσει, και πας εδώ και διαβάζεις ΑΝ υπάρχει κάποιο πρόβλημα.
  Απάντηση
#3
xalia ta pao apo agglika alla θα προσπαθησω να καταλαβω αν μπορεσω αλλιως νομιζω πως θα το μεταφρασεις παλια εσυ φιλε μου και συγνωμη αλλα ασε να το δω πρωτα εγω παλι απλα ηθελα να κανω την αναβαθμιση γιατι αναβαθμιζει και το bluez kai eipa μηπως σιαξει και το bluetooth alla ola pane opos nane.
  Απάντηση
#4
φιλε μου στη 2η σελιδα που εστειλες δινω με την σειρα ολες τις εντολες και θα λυθη το προβλημα;;;;
  Απάντηση
#5
Σιγά λίγο....

Διάβασα λίγο το post [της πρώτης σελίδας] και έχω νέα...
Δίνεις κατά σειρά και μία μία προσέχοντας ΤΙ ΛΕΕΙ στην έξοδο της εντολής:

Παράθεση:comm -12 <(pacman -Qqm) <(pacman -Qqo /bin /sbin /usr/sbin | sort -u)

Αν σου βγάλει αρχεία εδώ, σταματάς και κάνεις paste την έξοδο...
Αν όχι, προχωράς στις παρακάτω:

Παράθεση: pacman -Syu --ignore filesystem
pacman -Su

Και θα είσαι οκ...
Ελπίζω δηλαδή, αλλά αυτή είναι η λύση που προτείνεται....
  Απάντηση
#6
φιλε μου εφτασα μεχρι τη 2η εντολη αλλα εβγαλε και αλλο προβλημα.\
δες
Κώδικας:
[root@blackm76 makis]# comm -12 <(pacman -Qqm) <(pacman -Qqo /bin /sbin /usr/sbin | sort -u)
[root@blackm76 makis]# pacman -Syu --ignore filesystem
:: Συγχρονισμός βάσεων πακέτων...
core ενημερωμένο
extra ενημερωμένο
community ενημερωμένο
multilib ενημερωμένο
:: Έναρξη πλήρους αναβάθμισης συστήματος...
προσοχή: filesystem: παράβλεψη αναβάθμισης πακέτου (2013.03-2 => 2013.05-2)
επίλυση εξαρτήσεων...
διερεύνηση διενέξεων...

Πακέτα (58): blender-8:2.67.57180-1  bluez-4.101-2  cdrkit-1.1.11-3  cheese-3.8.2-2  clutter-gst-2.0.4-2  coreutils-8.21-2  cryptsetup-1.6.1-2  device-mapper-2.02.98-4  dhcpcd-5.6.8-3
            digikam-3.2.0-1  e2fsprogs-1.42.7-2  fuse-2.9.2-3  gcc-4.8.1-1  gcc-libs-4.8.1-1  gconf-3.2.6-2  giflib-4.2.1-2  glibc-2.17-6  inetutils-1.9.1-6  iproute2-3.9.0-2
            iptables-1.4.19.1-1  iw-3.10-2  kmod-13-2  lib32-gcc-libs-4.8.1-1  libatasmart-0.19-2  libbonobo-2.32.1-4  libkface-3.2.0-1  libkgeomap-3.2.0-1  libltdl-2.4.2-9  libmbim-1.0.0-1
            libogg-1.3.1-1  libsasl-2.1.26-4  libtool-2.4.2-9  lvm2-2.02.98-4  modemmanager-0.7.990-5  net-tools-1.60.20130531git-1  netctl-1.1-1  networkmanager-0.9.8.0-4
            obex-data-server-0.4.6-6  openobex-1.7-5  openresolv-3.5.4-3  pm-utils-1.4.1-6  ppp-2.4.5-6  rtmpdump-20121203-2  ruby-2.0.0_p195-1  sane-1.0.23-7  sed-4.2.2-3  shadow-4.1.5.1-6
            strigi-0.7.8-3  systemd-204-3  systemd-sysvcompat-204-3  sysvinit-tools-2.88-11  tar-1.26-4  udisks2-2.1.0-3  usbmuxd-1.0.8-2  util-linux-2.23.1-2  v4l-utils-0.9.5-2
            wpa_supplicant-2.0-4  zvbi-0.2.33-6

Συνολικό Μέγεθος Εγκατάστασης: 491,53 MiB
Καθαρό Μέγεθος Αναβάθμισης: 4,90 MiB

:: Συνέχιση εγκατάστασης; [Y/n] y
(58/58) έλεγχος κλειδιών                                                                                            [---------------------------------------------------------------------] 100%
(58/58) έλεγχος ακεραιότητας πακέτων                                                                                [---------------------------------------------------------------------] 100%
(58/58) φόρτωση αρχείων πακέτων                                                                                    [---------------------------------------------------------------------] 100%
(58/58) έλεγχος διενέξεων αρχείων                                                                                  [---------------------------------------------------------------------] 100%
σφάλμα: αποτυχία διεκπεραίωσης (διένεξη αρχείων)
digikam: το /usr/share/locale/el/LC_MESSAGES/libkipi.mo υπάρχει ήδη στο δίσκο
Προέκυψαν σφάλματα, δεν αναβαθμίστηκαν πακέτα.
[root@blackm76 makis]#
  Απάντηση
#7
Αυτό το σφάλμα, έχει να κάνει με την Ελληνική γλώσσα που έχεις περάσει.....τουλάχιστον αυτό δείχνει η διαδρομή του..
Αλλά και το libkipi είναι εξάρτηση εφαρμογών διαχείρισης εικόνας,,,
Δεν καταλαβαίνω γιατί έχει θέμα, αφού δεν γίνεται αναβάθμιση σε αυτά τα πακέτα -εκτός του digikam-.

Για δώσε ένα
Παράθεση:pacman -Rsn digikam kipi-plugins
και προσπάθησε να δώσεις πάλι την δεύτερη εντολή.

Το πολύ πολύ, τα εγκαθιστάς πάλι αυτά τα πακέτα.
  Απάντηση
#8
Edit:
Για δώσε -αν σου βγάλει πάλι σφάλμα η δεύτερη εντολή-
Παράθεση:find /bin /sbin /usr/sbin -exec pacman -Qo -- {} + >/dev/null
και κάνε paste εδώ την έξοδο ΑΝ υπάρχει.
  Απάντηση
#9
Μια με το systemd, μια με την python, μια με το /usr/lib, μια με το sbin... όλο κάτι τέτοια αυτογκόλ βάζει το Arch.
Διανομή για πολλά γέλια.
[Εικόνα: eksaptei.jpg]
  Απάντηση
#10
psyxroskianapodos, post: 10007, member: 129 είπε κι ελάλησε:Μια με το systemd, μια με την python, μια με το /usr/lib, μια με το sbin... όλο κάτι τέτοια αυτογκόλ βάζει το Arch.
Διανομή για πολλά γέλια.

Ναι μωρέ, δίκιο έχεις...
Όλο προβλήματα....
Φυσικά λύσεις υπάρχουν, και είναι σε απόσταση 2 - 3 εντολών σε κονσόλα, αλλά ποιος κάθεται τώρα να ασχολείται...

Δεν έμενα με τα windows να είχα την ησυχία μου και την άγνοιά μου....

Ένα ένα αν πάρουμε αυτά που αναφέρεις, θα συμφωνήσεις -ακόμα- και εσύ, πως δεν χρειάζεται παραπάνω από 2 - 3 εντολές ώστε να γίνει το σύστημα ξανα λειτουργικό.
πχ στην μετάβαση στο systemd που τόσα διαβάζω για το κακό arch και τι σκατά θέλει και αλλάζει τα πράματα -η οποία έγινε ώστε να απεμπλακεί το arch από daemons και άσχετα αρχεία όπως το rc.conf- ήταν θέμα συμπλήρωσης 3 λέξεων στην γραμμή του kernel..Φοβερό και δύσκολο.
Σίγουρα το systemd είναι πιο φιλικό στον χρήστη από το να ψάχνει πού πρέπει να εκκινήσει τον κάθε daemon στο rc.conf ώστε να έχει επιτυχές boot, δεν συμφωνείς?

Υπάρχουν διανομές, που δεν απαιτείται τόσο η παρέμβαση του χρήστη και όλα γίνονται -ή δεν γίνονται καθόλου- εν αγνοία του και πάντως χωρίς να γνωρίζει γιατί και πως...
Υπάρχουν και άλλες διανομές που σε αυτές απαιτείται η παρέμβαση...

Ο καθένας επιλέγει ότι του αρέσει....και κυρίως τον βολεύει ή αυτό που υποθέτει πως δεν θα τον κουράσει.
  Απάντηση


Ίσως Σχετικά Νήματα...
Νήμα Άτομο Απαντήσεις Βλεφαριάσματα Τελευταία Ανάρτηση
  προβλημα με αναβαθμιση. blackm76 5 1.952 14.02.2017 15:26
Τελευταία Ανάρτηση: blackm76
  Πρόβλημα με αναβάθμιση συστήματος [Λύθηκε] blackm76 11 1.797 07.06.2014 01:11
Τελευταία Ανάρτηση: blackm76
  αναβαθμιση συστηματος blackm76 5 748 11.11.2013 15:09
Τελευταία Ανάρτηση: blackm76

Πάμε στο Forum:


Πλάσματα σουλατσάρουν στο νήμα: 1 Επισκέπτης(ες)